MySagePay
Login >

Poodle and SSLv3.0

Following on from the recent Poodle vunerability we wanted to give you more information on the steps we have taken, and any steps you and shoppers will need to take in order to make sure you are not at risk.  

We have carried out extensive checks to ensure that our systems are unaffected and we are confident this is not the case.

Sage Pay have taken the step to eliminate the risk to your shoppers by by disabling hosted page transactions by any browser that doesn't support TLS.

On the 19th January 2015 we have disabled SSLv3.0 on our test environment.  

This means that if you are not able to connect or access the TEST environment you will need to update the browser you are using.  

For more information on Poodle, and what steps you will need to take please select any of the links below - 

Poodle - Are you affected?

SSLv3.0 - Technical Guide

SSLv3 (Poodle) - Update

Sage Pay Blog - An update from our CTO